Загрузка
Наше Android приложение

Будьте в курсе наших
акций и новостей

Cats Lab Blog

Обновление облака 18.0.44

Plesk Obsidian 18.0.44 24 May 2022 We are glad to introduce the production version of the Laravel Toolkit extension. Added the following improvements to the extension: Use the extension in Plesk for Windows. Deploy a Laravel skeleton application on a domain. Create a website with the latest Laravel version with just a few clicks ( Websites & Domains > Add Domain > Laravel site ). Introduced the new “Deployment” section that makes it possible to use custom scripts to deploy applications. View the extension logs in Log Browser. (Plesk for Linux) Run artisan and composer commands without having to specify the whole path. Enjoy smoother transitions between screens with introduced content placeholders. When Plesk loads application cards as well as Composer and Artisan sections, you can now see their rough skeletons. Multiple UX improvements. The new “Add Domain” screen is now enabled by default. Learn more about this improvement . The /root/.my.cnf file that contains the password for the MySQL console client no longer blocks Plesk automatic updates. The interface in Power User View is now always set to “All webspaces” unless users select the desired webspace themselves. As soon as the Plesk administrator creates the second webspace, they now see a hint on how to switch between webspaces. Made the transitions between domain cards smoother by introducing content placeholders: when Plesk loads a domain card, users now see its rough skeleton. It is now possible to change IP addresses of subscriptions with “Forwarding” and “No hosting” types. Made it more clear for users how to add SRV DNS records: the “Service name” and “Protocol” fields now have correct examples. (PPP-56626) If Plesk has a subscription with the limit on domain aliases or subdomains set to zero, this no longer prevents the Plesk administrator from creating domain aliases and subdomains in the Plesk interface. (PPPM-13534) Specifying empty values of panel.ini settings no longer stops the domains’ “PHP Settings” page from being loaded. (PPPM-13516) Subscriptions’ names in Customer Panel are now again sorted in alphabetical order. (PPPM-13517) File Manager now correctly uploads directories with empty files or directories inside. (PPPM-13535) Clearing the “Mail messages” checkbox in Backup Manager > Back Up no longer resets the backup type to “Incremental”. (PPPM-13503) Changing PHP settings of a locked subscription no longer overrides them with the default PHP settings of the service plan the subscription was based on. (PPPM-11555) Operations with multiple items selected from the list now again work in Plesk extensions. (PPPM-13548) Increased the length of the “TXT record” text field for the following types of DNS records: TXT, MX, DS, and CAA. (PPP-56760) Plesk again shows the content of the Application Catalog categories (“All Available Applications” > “Web”, “Collaboration”, and so on). (PPPM-13546) Restoring a domain from a backup now preserves custom TTL values of the domain’s DNS records. (PPPM-13426) Linux The console now works using a domain’s PHP version instead of the system PHP. Customers can now run artisan, composer, and other commands without having to specify the whole path. To propagate and turn on the feature for all subscriptions, run the plesk bin php_settings --update-all command. To use the feature in Scheduled Tasks, prepend the cron command with the following: export PATH="/opt/plesk/phpenv/bin:$PATH"; eval "$(phpenv init -)"; To disable the feature and bring back how the console worked before, add the following lines to the panel.ini file: [php] phpenv = off Note: The feature works for Plesk PHP handlers only. It does not work for custom PHP handlers and CloudLinux with CageFS. Ubuntu 22.04 is now supported, with certain limitations . You can use the dist-upgrade procedure to upgrade your OS from Ubuntu 20.04 to Ubuntu 22.04 . It is now possible to customize the client_max_body_size nginx directive in the Plesk interface, via the CLI, and via the XML API. It is now possible to change a database user password on the remote database server Percona MySQL 8.0.23. (PPPM-13538) The “PHP-FPM settings” section in a domain’s PHP settings is now present for custom PHP handlers. (PPPM-13507) If Apache-only hosting is turned on, third-party services that use the “Host” header validation (for example, Grafana) now work. (PPP-56778) Log rotation now works correctly after updating to Plesk Obsidian 18.0.43 even if /usr/local/psa/etc/logrotate.conf was customized. (PPPM-13519) Fixed the error message shown when a password is not complex enough for the the “Very Strong” password strength policy. (PPPM-13550) In Plesk on Debian 10 and AlmaLinux 8, a start, stop, or restart of the dedicated PHP-FPM handler no longer fails with the “Unable to stop service: Variable “$actionType” got invalid value “stop”” error. (PPPM-13547) It is no longer possible bypass email sending restrictions for Postfix and qmail by using the -bs option with the sendmail wrapper. (PPPM-13497) When editing a domain’s PHP settings in the “Common settings” section, the cursor no longer jumps to the end of the text box. (PPPM-13554) On certain servers, Plesk no longer runs its Daily Maintenance tasks significantly longer than 24 hours. (PPPM-13532) Collecting statistics for a domain with a large number of files (about one million) now consumes significantly less RAM. (PPPM-13415) BIND no longer fails to start if Plesk has websites with enabled DNS zones but absent NS records. (PPPM-13468) Windows It is now possible to use the Laravel Toolkit extension. Backup restoration no longer fails if the DNS server was deleted from Plesk and a custom DNS service is used (for example, DigitalOcean DNS). (PPPM-13511) When users select the “Tradeoff” or “Thorough” configurations in ModSecurity, they now see the confirmation dialog, which informs that these configurations may disrupt operation of WordPress websites. (PPPM-13504) Third-Party Component Updates Updated PHP used by Plesk to version 7.4.29. Updated libcurl to version 7.83.0. Windows Updated POCO to version 1.11.2. Updated ASP.NET Core 6.0 to version 6.0.5. Updated ASP.NET Core 5.0 to version 5.0.17. Updated ASP.NET Core 3.1 to version 3.1.25. ionCube Loader is no longer shipped with Plesk because of stability issues. To use ionCube Loader, install it manually . Note: The already installed ionCube Loader component continues to work but PHP updates no longer update the component. Excluded the myLittleAdmin component from the “Full Installation” preset and marked the component as outdated. Note: The vendor does not support myLittleAdmin since 2013. Using outdated components is not secure. You can still install the component at your own risk by doing the following: (During Plesk installation) Select the “Custom” installation type and then select myLittleAdmin. (After Plesk installation) Run the plesk installer add --component mylittleadmin command. Plesk Migrator 2.21.8 23 May 2022 Updated translations. Laravel Toolkit 1.1.0 23 May 2022 Introduced the new ‘Deployment’ section that makes it possible to use custom scripts to deploy applications. Deploy a Laravel skeleton application on a domain. Create a website with the latest Laravel version with just a few clicks ( Websites & Domains > Add Domain > Laravel site ). View the extension logs in Log Browser. (Plesk for Linux) Run artisan and composer commands without having to specify the whole path. Enjoy smoother transitions between screens with introduced content placeholders. UX improvements. Social Login 1.5.2 19 May 2022 The option to log in to Plesk using My Plesk/Plesk 360 account has been disabled. Node.js 2.1.3 18 May 2022 The extension no longer tries to install Node.js version 18 or higher if glibc version 2.27 or earlier is installed on the server. (EXTNODEJS-215) PHP Updates 16 May 2022 Updated PHP 8.1 to version 8.1.6. Updated PHP 8.0 to version 8.0.19. Slave DNS Manager 1.10.1 13 May 2022 Removal of DNS zones is now again synced between Plesk and secondary DNS servers that use BIND 9.14 and later. (EXTPLESK-3353) Plesk Email Security 1.3.3 13 May 2022 Linux The extension can now install and use Amavis in Plesk on Red Hat Enterprise Linux 8. (EXTPLESK-3420) Ruby 1.4.3 5 May 2022 Updated Ruby 2.6 to version 2.6.10. SSL It! 1.10.3 22 April 2022 An unwanted security warning no longer appears if the Sectigo and Digicert extensions are not installed. (EXTSSLIT-1851) Now the option to choose the certificate’s vendor does not appear if the Sectigo and Digicert extensions are not installed. (EXTSSLIT-1890) It is no longer possible to issue a certificate that secures only domain’s aliases, but not the main domain. Such certificates can not be installed in Plesk. (EXTSSLIT-1899) Monitoring 2.3.3 22 April 2022 It is now possible to configure the 360 Monitoring integration via the CLI. To see the CLI commands, run plesk ext monitoring --cloud . Node.js 2.1.2 20 April 2022 Internal improvements. PHP Updates 18 April 2022 Updated PHP 8.1 to version 8.1.5. Updated PHP 8.0 to version 8.0.18. Updated PHP 7.4 to version 7.4.29. Linux Updated Xdebug to version 3.1.4 for PHP 8.1, 8.0, 7.4. Docker 1.5.3 18 April 2022 Internal improvements.


Yuriy

Cats Lab Blog

Обновление облака

PHP Updates 18 April 2022 Updated PHP 8.1 to version 8.1.5. Updated PHP 8.0 to version 8.0.18. Updated PHP 7.4 to version 7.4.29. Linux Updated Xdebug to version 3.1.4 for PHP 8.1, 8.0, 7.4. Docker 1.5.3 18 April 2022 Internal improvements. Plesk Obsidian 18.0.43 Update 1 15 April 2022 Linux Updating Plesk to version 18.0.43 no longer fails when MySQL Community Server is used. (PPPM-13514) WordPress Toolkit 5.10.2 15 April 2022 WordPress plugins and themes will now be properly autoupdated by WordPress Toolkit after the corresponding autoupdate settings are enabled and “Take over wp-cron.php” option is switched on. Twenty Two theme now properly conforms to autoupdate settings when it’s installed during WordPress core update. (EXTWPTOOLK-8831) “WordPress Vulnerabilities” screen now displays a hint if WordPress core update is required to update a vulnerable plugin or theme. (EXTWPTOOLK-8538) Linux Smart Updates now work properly when proxy mode is disabled for nginx. (EXTWPTOOLK-8798) WordPress widgets can now be managed on nginx + PHP-FPM when permalinks are used. (EXTWPTOOLK-8839) Windows Users can delete plugins that were uploaded manually on the global “Plugins” tab. (EXTWPTOOLK-8695) WordPress can now be installed if PHP 8.1 is used. (EXTWPTOOLK-9045)


Yuriy